Malcolm rig CRASHING?

Discuss anything related to the Malcolm Rig here!
Post Reply
User avatar
admin
Site Admin
Posts: 501
Joined: Thu Jul 21, 2011 12:51 pm

Malcolm rig CRASHING?

Post by admin » Tue Apr 28, 2020 3:49 pm

Maya has made very large changes in the last few versions which make rigs more likely to crash Maya. Here are a few things you can try.

If you're using Maya 2018 First try installing Maya 2018 Update 4 or 5. If you're using Maya 2019, try the latest update version.
(Updates are available on the Updates tab on autodesk's site)

If that doesn't fix it: Next, assuming Parallel execution mode is on, try turning on or off GPU Override:
Settings/Preferences>Settings>Animation>Evaluation>GPU Override

Next try: Viewport, Renderer>Viewport 2.0 Options, Turn off Consolidate World.

If that doesn't help, change Settings/Preferences>Settings>Animation>Evaluation Mode to DG instead of Parallel.
That will make the scene playback slower.

Another thing you can try instead of turning off Parallel mode is resetting your preferences. You can try this if you are getting frequent, regular crashes.
Just close Maya then rename your C:\Users\yourname\Documents\maya\2018 to 2018badprefs(for example)
Then restart Maya. It will make an all new preferences folder.
That will be disorienting because you'll lose your custom hotkeys and shelves.
If the crashing is often enough, you can try to reestablish a few hotkeys and buttons enough to test if the resetting helped.
If it stopped crashing, either remake your hotkeys again by looking at another version of Maya where you have the hotkeys or copy over your hotkeys and shelves one by one and see when the crashing starts happening again.

Post Reply

Who is online

Users browsing this forum: Majestic-12 [Bot] and 3 guests